Live Chat Tutor unavailable
Incident Report for Big Ideas Math
Resolved
Live Chat Tutor features are available again.
Posted Dec 13, 2023 - 18:08 EST
Investigating
Live Chat Tutor features within Dynamic Student Edition and Dynamic Assessment System are unavailable. We are currently investigating.
Posted Dec 13, 2023 - 16:56 EST