AWS outage

Incident Report for Big Ideas Math

Resolved

All services have returned to normal. We will be monitoring services to ensure continued resolution.
Posted Oct 20, 2025 - 17:07 EDT

Update

It appears that a few of our services are experiencing delays around assignment editing/creation and assignment reporting. While we are still seeing limited impact, it may cause a degraded experience for some users. We are continuing to monitor events and will update here as additional information becomes available.
Posted Oct 20, 2025 - 13:25 EDT

Monitoring

While Big Ideas Math is observing limited impacts from the ongoing AWS outage, we continue to monitor events and will respond if needed.
Posted Oct 20, 2025 - 12:24 EDT
This incident affected: Big Ideas Math (Big Ideas Math Web Site).