eBook Library Issue Affecting Teachers - No matching records found.
Incident Report for Big Ideas Math
Resolved
The issue affecting the teacher eBook has been resolved. We thank you for your patience and please contact our Support team to assist with any questions or issues.
Posted Oct 05, 2023 - 09:47 EDT
Identified
The issue affecting the display of eBooks for teachers has been identified and a fix is being worked on. We thank you for your patience during this time.
Posted Oct 04, 2023 - 10:19 EDT
Investigating
We are currently investigating an issue that is affecting teacher's opening their eBook library and seeing the message 'No matching records found.' We apologize for any inconvenience and will continue to provide updates while we work on resolving this issue.
Posted Oct 02, 2023 - 11:00 EDT