Delayed Customer Support Response Time - Power Outage
Incident Report for Big Ideas Math
Resolved
Power has been restored to the area.
Posted Jan 09, 2024 - 12:38 EST
Identified
We are currently experiencing an unexpected power outage in the area that will affect the response time of the Customer Support team. Use of the Big Ideas Math platform is not affected by this outage.
Posted Jan 09, 2024 - 11:37 EST